---
id: CVE-2026-78192
title: >-
  WebDyne versions from 2.022 before 3.022 for Perl disclose application source
  to unauthenticated clients via the viewer in the default index page
summary: >-
  WebDyne versions from 2.022 before 3.022 for Perl disclose application source
  to unauthenticated clients via the viewer in the default index page.


  WebDyne's wrapper scripts, such as webdyne.psgi, enable the built-in index
  page by defaul…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: adp
cwe:
  - CWE-540
  - CWE-1188
product: WebDyne
affected:
  - WebDyne >= 2.022 < 3.022
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-06T13:48:52.872802Z'
published: '2026-10-31'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T13:49:14.664Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-78192'
references:
  - url: 'https://metacpan.org/release/ASPEER/WebDyne-3.022/changes'
tags:
  - cve.org
epss: 0.00223
epssPercentile: 0.12999
ingestedAt: '2026-11-05T16:24:31.547Z'
---

## Overview

WebDyne versions from 2.022 before 3.022 for Perl disclose application source to unauthenticated clients via the viewer in the default index page.

WebDyne's wrapper scripts, such as webdyne.psgi, enable the built-in index page by default. Its source viewer returns files under the document root named in the source parameter of an HTMX request, including .psp, .pm and .pl files.

A remote attacker can read the application's Perl code, including the __PERL__ blocks of .psp pages and any credentials they hold.

## Affected

- `WebDyne >= 2.022 < 3.022`

## Remediation

Upgrade to WebDyne 3.022 or later.
