---
id: CVE-2026-78684
title: >-
  vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and
  omits pixel-limit enforcement in its decode path
summary: >-
  vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and
  omits pixel-limit enforcement in its decode path. Unauthenticated attackers
  can activate DeepStream at request time to initialize the process-wide GPU
  decode p…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-400
vendor: vllm
product: vllm
affected:
  - vllm < 0.27.0
patched:
  - vllm 0.27.0
published: '2026-08-25'
updated: '2026-09-29'
sourceUpdated: '2026-09-29T12:52:51.410'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-78684'
references:
  - url: >-
      https://github.com/vllm-project/vllm/commit/e23b19309b8705b21c3b3ff4129c9974ba15a419
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-cqm8-jxg6-fqfq
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vllm-before-denial-of-service-via-deepstream-backend
    label: disclosure@vulncheck.com
tags:
  - nvd
  - osv
  - pip
ingestedAt: '2026-09-14T21:15:17.419Z'
epss: 0.00608
epssPercentile: 0.48877
aliases:
  - PYSEC-2026-4003
  - GHSA-cqm8-jxg6-fqfq
ecosystem: pip
---

## Overview

vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and omits pixel-limit enforcement in its decode path. Unauthenticated attackers can activate DeepStream at request time to initialize the process-wide GPU decode pool and submit video that bypasses resource controls, causing partial denial of service for concurrent requests.

## Affected

- `vllm < 0.27.0`

## Remediation

Upgrade past the affected range:

- `vllm 0.27.0`

## Package advisory (CVE-2026-78684)

Affected packages:

- `vllm < 0.27.0`

Patched in:

- `vllm 0.27.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-4003
