---
id: CVE-2026-79657
title: >-
  NLTK versions before 3.10.3 contain a remote code execution vulnerability in
  allowlisted pickle loaders that trust entire module namespaces instead of
  specific safe callables
summary: >-
  NLTK versions before 3.10.3 contain a remote code execution vulnerability in
  allowlisted pickle loaders that trust entire module namespaces instead of
  specific safe callables. Attackers can craft malicious pickle payloads
  invoking danger…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
  - CWE-693
vendor: nltk
product: nltk
affected:
  - nltk < 3.10.3
patched:
  - nltk 3.10.3
published: '2026-08-25'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T16:17:44.427'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-79657'
references:
  - url: 'https://github.com/nltk/nltk/security/advisories/GHSA-x99w-6fgc-pmfw'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/nltk-before-3.10.3-remote-code-execution-via-unsafe-pickle-deserialization
    label: disclosure@vulncheck.com
  - url: 'https://github.com/nltk/nltk/security/advisories/GHSA-x99w-6fgc-pmfw'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-79657.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-79657'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2523372'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-79657'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-79657'
  - url: >-
      https://github.com/nltk/nltk/commit/c3e37113742a1ebeeb4f2ca58941f320f98805ea
  - url: 'https://github.com/nltk/nltk'
  - url: 'https://github.com/nltk/nltk/releases/tag/v3.10.3'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2026-3735.yaml
  - url: 'https://github.com/advisories/GHSA-x99w-6fgc-pmfw'
  - url: 'https://access.redhat.com/errata/RHSA-2026:84734'
tags:
  - nvd
  - cve.org
  - exploit-available
  - csaf
  - vex
  - red-hat
  - osv
  - pip
  - ghsa
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-25T15:58:28.455681Z'
epss: 0.01267
epssPercentile: 0.69612
aliases:
  - GHSA-x99w-6fgc-pmfw
  - PYSEC-2026-3735
ecosystem: pip
scores:
  nvd: 9.8
  vendor: 8.8
ingestedAt: '2026-09-02T19:31:24.390Z'
---

## Overview

NLTK versions before 3.10.3 contain a remote code execution vulnerability in allowlisted pickle loaders that trust entire module namespaces instead of specific safe callables. Attackers can craft malicious pickle payloads invoking dangerous in-namespace functions like ReppTokenizer._execute and numpy.f2py.crackfortran.myeval through pickle REDUCE to execute arbitrary commands during model or tokenizer artifact loading.

## Affected

- `nltk < 3.10.3`

## Remediation

Upgrade past the affected range:

- `nltk 3.10.3`

## Package advisory (CVE-2026-79657)

Affected packages:

- `nltk < 3.10.3`

Patched in:

- `nltk 3.10.3`

Source: https://osv.dev/vulnerability/GHSA-x99w-6fgc-pmfw

## Vendor advisories

- **Red Hat VEX** · Important · affected: Lightspeed Core, OpenShift Lightspeed, Red Hat Ansible Automation Platform 2 · no fix planned: Red Hat Ansible Automation Platform 2, Lightspeed Core, OpenShift Lightspeed · updated 2026-10-19 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-79657.json)
- **RHSA-2026:84734** · Red Hat · fixed in: Red Hat OpenShift AI 3.4 · released 2026-10-19 · [advisory](https://access.redhat.com/errata/RHSA-2026:84734)
