---
id: CVE-2026-79715
title: >-
  IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.9 could
  allow a local attacker to traverse directories on the system
summary: >-
  IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.9 could
  allow a local attacker to traverse directories on the system. An attacker
  could use a specially crafted application archive to write files outside the
  intended di…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N'
cwe:
  - CWE-22
vendor: IBM
product: WebSphere Application Server - Liberty
affected:
  - websphere_application_server_-_liberty >= 17.0.0.3 <= 26.0.0.9
published: '2026-10-13'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T18:18:37.537'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-79715'
references:
  - url: 'https://www.ibm.com/support/pages/node/7291394'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00139
epssPercentile: 0.03232
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-15T20:24:29.574530Z'
ingestedAt: '2026-10-13T21:58:14.189Z'
---

## Overview

IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.9 could allow a local attacker to traverse directories on the system. An attacker could use a specially crafted application archive to write files outside the intended directory.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
