---
id: CVE-2026-81683
title: openssl_encrypt before 1.4.9 Plaintext Private Key Storage
summary: >-
  openssl_encrypt (pip package openssl-encrypt) versions 1.4.8 and earlier store
  an mTLS client private key in cleartext within a world-readable (0644)
  SharedPreferences file via the desktop GUI's Settings screen 'combined
  certificate and …
severity: high
cvss: 8.4
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-312
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-08-27T18:19:21.836541Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:18.855Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81683'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-r8gw-6hfj-98jw
    label: GitHub Security Advisory (GHSA-r8gw-6hfj-98jw)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-plaintext-private-key-storage
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Plaintext Private Key
      Storage
tags:
  - cve.org
  - osv
  - pip
  - score-dispute
epss: 0.00071
epssPercentile: 0.00041
aliases:
  - PYSEC-2026-3792
  - GHSA-r8gw-6hfj-98jw
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
scores:
  cna: 8.4
  osv: 5.5
ingestedAt: '2026-09-03T19:32:11.984Z'
---

## Overview

openssl_encrypt (pip package openssl-encrypt) versions 1.4.8 and earlier store an mTLS client private key in cleartext within a world-readable (0644) SharedPreferences file via the desktop GUI's Settings screen 'combined certificate and private key' PEM field. A local attacker with file system access can read the exposed private key. Version 1.4.9 writes the PEM to a dedicated 0600 file, keeps only its path in SharedPreferences, and migrates/scrubs existing cleartext values.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81683)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3792
