---
id: CVE-2026-81689
title: openssl_encrypt before 1.4.9 Weak Pepper Key Derivation
summary: >-
  openssl_encrypt versions before 1.4.9 derive the remote-pepper wrap key using
  unsalted HKDF-SHA256 or bare SHA-256 of the password, allowing identical keys
  across all users and files. Attackers with access to wrapped pepper blobs can
  pre…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-916
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-27T18:38:50.371056Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:22.785Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81689'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-3v63-778v-3mvp
    label: GitHub Security Advisory (GHSA-3v63-778v-3mvp)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-weak-pepper-key-derivation
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Weak Pepper Key
      Derivation
tags:
  - cve.org
  - osv
  - pip
epss: 0.00272
epssPercentile: 0.19403
aliases:
  - PYSEC-2026-3959
  - GHSA-3v63-778v-3mvp
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-12T03:13:01.743Z'
---

## Overview

openssl_encrypt versions before 1.4.9 derive the remote-pepper wrap key using unsalted HKDF-SHA256 or bare SHA-256 of the password, allowing identical keys across all users and files. Attackers with access to wrapped pepper blobs can precompute a single dictionary table and perform fleet-wide offline password guessing at hardware speed to recover user passwords.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81689)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3959
