---
id: CVE-2026-81691
title: openssl_encrypt before 1.4.9 Credential Leakage via Unvalidated Server URLs
summary: >-
  openssl_encrypt versions before 1.4.9 fail to validate server URLs in login
  and register_with_email functions, accepting unencrypted http:// URLs and
  unconfigured hosts. Attackers on the network path can intercept cleartext
  credentials i…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-319
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-27T17:51:57.438583Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:24.082Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81691'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-xr64-hcxg-4ghr
    label: GitHub Security Advisory (GHSA-xr64-hcxg-4ghr)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-credential-leakage-via-unvalidated-server-urls
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Credential Leakage via
      Unvalidated Server URLs
tags:
  - cve.org
  - osv
  - pip
epss: 0.00272
epssPercentile: 0.19403
aliases:
  - PYSEC-2026-3797
  - GHSA-xr64-hcxg-4ghr
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-03T19:32:12.197Z'
---

## Overview

openssl_encrypt versions before 1.4.9 fail to validate server URLs in login and register_with_email functions, accepting unencrypted http:// URLs and unconfigured hosts. Attackers on the network path can intercept cleartext credentials including client_id, passwords, and JWTs to achieve full keyserver account takeover.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81691)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3797
