---
id: CVE-2026-81698
title: openssl_encrypt before 1.4.9 Shell Injection via info command
summary: >-
  openssl_encrypt versions before 1.4.9 contain a shell injection vulnerability
  in the info command's reconstructed CLI block that interpolates untrusted
  metadata fields without quoting. Attackers can craft metadata values like
  pepper_name…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-78
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-08-27T18:20:34.415014Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:28.523Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81698'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-gw2m-mj6q-59hc
    label: GitHub Security Advisory (GHSA-gw2m-mj6q-59hc)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-shell-injection-via-info-command
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Shell Injection via info
      command
tags:
  - cve.org
  - osv
  - pip
epss: 0.00427
epssPercentile: 0.3675
aliases:
  - PYSEC-2026-3776
  - GHSA-gw2m-mj6q-59hc
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
scores:
  cna: 7.5
  osv: 8.8
ingestedAt: '2026-09-02T19:31:26.074Z'
---

## Overview

openssl_encrypt versions before 1.4.9 contain a shell injection vulnerability in the info command's reconstructed CLI block that interpolates untrusted metadata fields without quoting. Attackers can craft metadata values like pepper_name containing shell commands that execute when users copy the printed CLI block into a shell.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81698)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3776
