---
id: CVE-2026-81700
title: openssl_encrypt before 1.4.9 GPG Signature Verification Bypass
summary: >-
  openssl_encrypt versions before 1.4.9 contain a signature verification
  vulnerability in gpg_runner.verify_detached that accepts revoked and expired
  keys by only checking VALIDSIG status without inspecting REVKEYSIG, EXPKEYSIG,
  or gpg exi…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-347
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-27T19:26:43.477225Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:29.835Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81700'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-x38r-8wf3-q9hq
    label: GitHub Security Advisory (GHSA-x38r-8wf3-q9hq)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-gpg-signature-verification-bypass
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 GPG Signature
      Verification Bypass
tags:
  - cve.org
  - osv
  - pip
epss: 0.00351
epssPercentile: 0.28558
aliases:
  - PYSEC-2026-3777
  - GHSA-x38r-8wf3-q9hq
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-02T19:31:26.115Z'
---

## Overview

openssl_encrypt versions before 1.4.9 contain a signature verification vulnerability in gpg_runner.verify_detached that accepts revoked and expired keys by only checking VALIDSIG status without inspecting REVKEYSIG, EXPKEYSIG, or gpg exit codes. Attackers holding compromised-then-revoked signing keys or expired project keys can bypass signature verification to execute malicious plugins in the host process.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81700)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3777
