---
id: CVE-2026-81701
title: openssl_encrypt before 1.4.9 Arbitrary Code Execution via unsigned plugin
summary: >-
  openssl_encrypt versions before 1.4.9 use a denylist to identify trusted
  built-in plugins, allowing unsigned plugins in top-level plugins/ directories
  and unknown subdirectories to bypass signature verification. Attackers can
  place malic…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-347
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-08-27T17:40:43.830805Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:30.463Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81701'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-wxx9-p55f-wm34
    label: GitHub Security Advisory (GHSA-wxx9-p55f-wm34)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-arbitrary-code-execution-via-unsigned-plugin
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Arbitrary Code Execution
      via unsigned plugin
tags:
  - cve.org
  - osv
  - pip
epss: 0.00426
epssPercentile: 0.36649
aliases:
  - PYSEC-2026-3778
  - GHSA-wxx9-p55f-wm34
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-02T19:31:26.156Z'
---

## Overview

openssl_encrypt versions before 1.4.9 use a denylist to identify trusted built-in plugins, allowing unsigned plugins in top-level plugins/ directories and unknown subdirectories to bypass signature verification. Attackers can place malicious unsigned plugins following documented installation paths to achieve arbitrary code execution in the CLI process with access to passwords and cryptographic keys.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81701)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3778
