---
id: CVE-2026-81705
title: openssl-encrypt before 1.4.9 Password Cleartext Leak via Debug
summary: >-
  openssl-encrypt before 1.4.9 fails to redact the file password in its --debug
  argv dump when the password is supplied via bundled short-option spellings
  (e.g. -apHunter2) or abbreviated long-option spellings (e.g. --passw). The
  sanitizer…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-532
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-08-27T19:27:35.639597Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:33.058Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81705'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-jgvm-7jxv-cgcc
    label: GitHub Security Advisory (GHSA-jgvm-7jxv-cgcc)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-password-cleartext-leak-via-debug
    label: >-
      VulnCheck Advisory: openssl-encrypt before 1.4.9 Password Cleartext Leak
      via Debug
tags:
  - cve.org
  - osv
  - pip
epss: 0.0044
epssPercentile: 0.38072
aliases:
  - PYSEC-2026-3780
  - GHSA-jgvm-7jxv-cgcc
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-02T19:31:26.238Z'
---

## Overview

openssl-encrypt before 1.4.9 fails to redact the file password in its --debug argv dump when the password is supplied via bundled short-option spellings (e.g. -apHunter2) or abbreviated long-option spellings (e.g. --passw). The sanitizer only recognized exact option names, --option=value forms, and tokens starting with -p, so these spellings bypass the redaction chokepoint and the cleartext password is written to stderr. Anyone with access to that output (terminal scrollback, merged 2>&1 output, CI job logs, or the GUI's persistent debug log) can recover the password.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81705)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3780
