---
id: CVE-2026-81716
title: openssl_encrypt before 1.4.9 Plugin Sandbox Path Traversal
summary: >-
  openssl_encrypt (pip: openssl-encrypt) versions before 1.4.9 contain a path
  traversal flaw in PluginSandbox._is_safe_path, which authorized file access
  using a bare string-prefix match. A sandboxed plugin without the READ_FILES
  permissio…
severity: medium
cvss: 5.2
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-22
vendor: jahlives
product: openssl_encrypt
affected:
  - openssl_encrypt < 1.4.9
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-08-27T19:28:17.572595Z'
published: '2026-08-27'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T15:21:36.350Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-81716'
references:
  - url: >-
      https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-vr4h-5xqv-xxxf
    label: GitHub Security Advisory (GHSA-vr4h-5xqv-xxxf)
  - url: >-
      https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-plugin-sandbox-path-traversal
    label: >-
      VulnCheck Advisory: openssl_encrypt before 1.4.9 Plugin Sandbox Path
      Traversal
tags:
  - cve.org
  - osv
  - pip
epss: 0.00261
epssPercentile: 0.17795
aliases:
  - PYSEC-2026-3800
  - GHSA-vr4h-5xqv-xxxf
ecosystem: pip
patched:
  - openssl-encrypt 1.4.9
ingestedAt: '2026-09-03T19:32:12.324Z'
---

## Overview

openssl_encrypt (pip: openssl-encrypt) versions before 1.4.9 contain a path traversal flaw in PluginSandbox._is_safe_path, which authorized file access using a bare string-prefix match. A sandboxed plugin without the READ_FILES permission could read or write another plugin's directory that merely shares a name prefix (e.g., .../plugins/foobar matching allowed .../plugins/foo), breaking per-plugin isolation within the same user. Fixed by matching each allowed directory exactly or with a trailing path separator.

## Affected

- `openssl_encrypt < 1.4.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-81716)

Affected packages:

- `openssl-encrypt < 1.4.9`

Patched in:

- `openssl-encrypt 1.4.9`

Source: https://osv.dev/vulnerability/PYSEC-2026-3800
