---
id: CVE-2026-81725
title: >-
  nltk: NLTK: Regular Expression Denial of Service via malformed TEI blocks
  (CVE-2026-81725)
summary: >-
  A flaw was found in NLTK, specifically within the Pl196xCorpusReader
  component. A remote attacker can exploit this by supplying malformed Text
  Encoding Initiative (TEI) blocks containing numerous unmatched opening tags.
  This triggers a reg…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: vendor
cwe:
  - CWE-1333
  - CWE-400
vendor: Red Hat
product: Red Hat OpenShift AI 3.4
affected:
  - exploit_intelligence
  - lightspeed_core
  - openshift_lightspeed
  - ansible_automation_platform 2
  - openshift_ai_rhoai
  - openshift_ai 3.4
patched:
  - openshift_ai 3.4
published: '2026-08-27'
updated: '2026-10-19'
sourceUpdated: '2026-10-19T11:48:21+00:00'
source: CSAF
sourceUrl: 'https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-81725.json'
references:
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-81725.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-81725'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2525094'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-81725'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-81725'
  - url: 'https://github.com/nltk/nltk/security/advisories/GHSA-8mpw-7fpc-4gqj'
  - url: >-
      https://www.vulncheck.com/advisories/nltk-before-3.10.3-regular-expression-denial-of-service-via-pl196xcorpusreader
  - url: 'https://access.redhat.com/errata/RHSA-2026:84734'
  - url: >-
      https://github.com/nltk/nltk/commit/7808692d451b962711005d954859bb83aabcf8fa
  - url: 'https://github.com/nltk/nltk'
  - url: 'https://github.com/nltk/nltk/releases/tag/v3.10.3'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2026-3752.yaml
  - url: 'https://github.com/advisories/GHSA-8mpw-7fpc-4gqj'
tags:
  - csaf
  - vex
  - red-hat
  - osv
  - pip
  - ghsa
epss: 0.00369
epssPercentile: 0.30593
aliases:
  - GHSA-8mpw-7fpc-4gqj
  - PYSEC-2026-3752
ecosystem: pip
ingestedAt: '2026-09-02T19:31:25.161Z'
---

## Overview

A flaw was found in NLTK, specifically within the Pl196xCorpusReader component. A remote attacker can exploit this by supplying malformed Text Encoding Initiative (TEI) blocks containing numerous unmatched opening tags. This triggers a regular expression denial of service (ReDoS) vulnerability, causing quadratic CPU consumption and leading to a denial of service.

## Vendor advisories

- **RHSA-2026:84734** · Red Hat · fixed in: Red Hat OpenShift AI 3.4 · released 2026-10-19 · [advisory](https://access.redhat.com/errata/RHSA-2026:84734)
- **Red Hat VEX** · Moderate · affected: Exploit Intelligence, Lightspeed Core, OpenShift Lightspeed, Red Hat Ansible Automation Platform 2, Red Hat OpenShift AI (RHOAI) · no fix planned: Exploit Intelligence, Lightspeed Core, OpenShift Lightspeed, Red Hat Ansible Automation Platform 2, … · updated 2026-10-19 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-81725.json)

**nltk: NLTK: Regular Expression Denial of Service via malformed TEI blocks** — rated Moderate by Red Hat. Released 2026-08-27, updated 2026-10-19.

Affected:

- Exploit Intelligence
- Lightspeed Core
- OpenShift Lightspeed
- Red Hat Ansible Automation Platform 2
- Red Hat OpenShift AI (RHOAI)

Fixed:

- Red Hat OpenShift AI 3.4

No fix planned:

- Exploit Intelligence
- Lightspeed Core
- OpenShift Lightspeed
- Red Hat Ansible Automation Platform 2
- Red Hat OpenShift AI (RHOAI)

Not affected:

- Red Hat OpenShift AI 3.4
- OpenShift Lightspeed

## Remediation

For Red Hat OpenShift AI 3.4.5 see the following documentation, which will be updated shortly for this release, for important instructions on how to upgrade your cluster and fully apply this errata update:

https://docs.redhat.com/en/documentation/red_hat_openshift_ai/ https://access.redhat.com/errata/RHSA-2026:84734

Workarounds / mitigations:

- Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.

## Package advisory (CVE-2026-81725)

Affected packages:

- `nltk < 3.10.3`

Patched in:

- `nltk 3.10.3`

Source: https://osv.dev/vulnerability/GHSA-8mpw-7fpc-4gqj
