---
id: CVE-2026-85436
title: >-
  MOOS essential-moos through 10.0.1 contains a buffer overflow vulnerability in
  CMOOSUDPLink::ReadPktFromArray() that allows remote attackers to corrupt heap
  memory by sending UDP datagrams with negative declared lengths
summary: >-
  MOOS essential-moos through 10.0.1 contains a buffer overflow vulnerability in
  CMOOSUDPLink::ReadPktFromArray() that allows remote attackers to corrupt heap
  memory by sending UDP datagrams with negative declared lengths. Attackers can
  se…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-191
vendor: themoos
product: essential-moos
affected:
  - essential-moos < 10.0.1
patched:
  - essential-moos 10.0.1
published: '2026-09-03'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T23:27:55.763'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-85436'
references:
  - url: 'https://github.com/themoos/essential-moos'
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/themoos/essential-moos/blob/b897ea86dba8b61412dc48ac0cfb5ff34cdaf5f6/Essentials/pMOOSBridge/MOOSUDPLink.cpp#L171
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/themoos/essential-moos/commit/613175fcf63fb9c6c5329c4ec57c2d18588b33e2
    label: disclosure@vulncheck.com
  - url: 'https://github.com/themoos/essential-moos/pull/21'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/moos-essential-moos-through-10.0.1-pmoosbridge-heap-corruption-via-negative-udp-length
    label: disclosure@vulncheck.com
tags:
  - nvd
epss: 0.02085
epssPercentile: 0.81468
ingestedAt: '2026-09-08T20:10:03.161Z'
---

## Overview

MOOS essential-moos through 10.0.1 contains a buffer overflow vulnerability in CMOOSUDPLink::ReadPktFromArray() that allows remote attackers to corrupt heap memory by sending UDP datagrams with negative declared lengths. Attackers can send crafted UDP packets to the configured UDPListen port to trigger an oversized memcpy operation that writes past the destination buffer, causing heap corruption and denial of service.

## Affected

- `essential-moos < 10.0.1`

## Remediation

Upgrade past the affected range:

- `essential-moos 10.0.1`
