---
id: CVE-2026-85487
title: >-
  A path traversal vulnerability exists in the HTTP service component of Brocade
  ASCG versions before 3.5.0
summary: >-
  A path traversal vulnerability exists in the HTTP service component of Brocade
  ASCG versions before 3.5.0. An unauthenticated attacker on the local network
  could send a manipulated API request to the service endpoint bypassing path
  restr…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-22
vendor: broadcom
product: brocade_active_support_connectivity_gateway
affected:
  - brocade_active_support_connectivity_gateway < 3.5.0
patched:
  - brocade_active_support_connectivity_gateway 3.5.0
published: '2026-10-08'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T18:48:55.573'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-85487'
references:
  - url: 'https://support.broadcom.com/external/content/SecurityAdvisories/0/38383'
    label: sirt@brocade.com
tags:
  - nvd
  - cve.org
epss: 0.00244
epssPercentile: 0.15518
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-08T17:47:24.026231Z'
scores:
  nvd: 8.8
  cna: 8.6
ingestedAt: '2026-10-08T07:18:54.846Z'
---

## Overview

A path traversal vulnerability exists in the HTTP service component of Brocade ASCG versions before 3.5.0. An unauthenticated attacker on the local network could send a manipulated API request to the service endpoint bypassing path restrictions to arbitrary file read, file write, or file deletion operations.

## Affected

- `brocade_active_support_connectivity_gateway < 3.5.0`

## Remediation

Upgrade past the affected range:

- `brocade_active_support_connectivity_gateway 3.5.0`
