---
id: CVE-2026-86243
title: >-
  Buffer over-read vulnerability in Apache Tomcat Native during the TLS
  handshake permits a malicious user to trigger a DoS via a JVM crash.




  This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0
  through 1.3.8
summary: >-
  Buffer over-read vulnerability in Apache Tomcat Native during the TLS
  handshake permits a malicious user to trigger a DoS via a JVM crash.




  This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0
  through 1.3.8. E…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-126
vendor: apache
product: tomcat_native
affected:
  - 'tomcat_native >= 1.3.0, < 1.3.9'
  - 'tomcat_native >= 2.0.0, < 2.0.16'
patched:
  - tomcat_native 2.0.16
published: '2026-09-23'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T13:53:46.107'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-86243'
references:
  - url: 'https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/09/23/31'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
epss: 0.00564
epssPercentile: 0.46695
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-23T15:28:53.132953Z'
ingestedAt: '2026-09-23T13:24:43.398Z'
---

## Overview

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.



This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.



Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

## Affected

- `tomcat_native >= 1.3.0, < 1.3.9`
- `tomcat_native >= 2.0.0, < 2.0.16`

## Remediation

Upgrade past the affected range:

- `tomcat_native 2.0.16`
