---
id: CVE-2026-86348
title: >-
  Mattermost versions <=11.9 11.0.9 11.4.8 11.7.7 10.22.11.0 fail to recover
  from handler panics, which allows an authenticated user to crash the plugin
  via a post-action request with an unexpected field type.
summary: >-
  Mattermost versions <=11.9 11.0.9 11.4.8 11.7.7 10.22.11.0 fail to recover
  from handler panics, which allows an authenticated user to crash the plugin
  via a post-action request with an unexpected field type.. Mattermost Advisory
  ID: MMSA…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-704
vendor: mattermost
product: mattermost_server
affected:
  - 'mattermost_server >= 10.11.0, < 10.11.23'
  - 'mattermost_server >= 11.7.0, < 11.7.8'
  - 'mattermost_server >= 11.8.0, < 11.8.5'
  - 'mattermost_server >= 11.9.0, < 11.9.1'
patched:
  - mattermost_server 11.9.1
published: '2026-09-14'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T19:28:53.743'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-86348'
references:
  - url: 'https://mattermost.com/security-updates'
    label: responsibledisclosure@mattermost.com
tags:
  - nvd
  - cve.org
epss: 0.00367
epssPercentile: 0.30401
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-14T19:13:36.957049Z'
ingestedAt: '2026-09-14T15:23:07.422Z'
---

## Overview

Mattermost versions <=11.9 11.0.9 11.4.8 11.7.7 10.22.11.0 fail to recover from handler panics, which allows an authenticated user to crash the plugin via a post-action request with an unexpected field type.. Mattermost Advisory ID: MMSA-2026-00701

## Affected

- `mattermost_server >= 10.11.0, < 10.11.23`
- `mattermost_server >= 11.7.0, < 11.7.8`
- `mattermost_server >= 11.8.0, < 11.8.5`
- `mattermost_server >= 11.9.0, < 11.9.1`

## Remediation

Upgrade past the affected range:

- `mattermost_server 11.9.1`
