---
id: CVE-2026-86787
title: >-
  The affiliate-toolkit  WordPress plugin before 3.9.1 does not prevent a
  low-privileged user from supplying a template body that its bundled templating
  engine compiles and executes as PHP, allowing users with the Contributor role
  or above…
summary: >-
  The affiliate-toolkit  WordPress plugin before 3.9.1 does not prevent a
  low-privileged user from supplying a template body that its bundled templating
  engine compiles and executes as PHP, allowing users with the Contributor role
  or above…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-94
published: '2026-10-14'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T16:14:02.800'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-86787'
references:
  - url: 'https://wpscan.com/vulnerability/ec9f71ee-fd44-46fc-989e-3b63ac04e8c3/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ingestedAt: '2026-10-14T07:21:04.842Z'
product: affiliate-toolkit
affected:
  - affiliate-toolkit >= 3.8.7 < 3.9.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-14T13:28:13.318345Z'
epss: 0.00396
epssPercentile: 0.33667
---

## Overview

The affiliate-toolkit  WordPress plugin before 3.9.1 does not prevent a low-privileged user from supplying a template body that its bundled templating engine compiles and executes as PHP, allowing users with the Contributor role or above to run arbitrary PHP code on the server.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
