---
id: CVE-2026-86794
title: >-
  Community Events 1.4.9 - 1.5.9 - Unauthenticated Stored XSS via Event
  Submission Form
summary: >-
  The Community Events WordPress plugin before 1.6.0 does not have authorisation
  or nonce checks when processing public event submissions, and does not escape
  several of the submitted values before outputting them in the administration
  das…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: adp
cwe:
  - CWE-79
product: Community Events
affected:
  - community_events >= 1.4.9 < 1.6.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T10:47:52.999713Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T10:56:05.527Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-86794'
references:
  - url: 'https://wpscan.com/vulnerability/058aa2e1-0b9c-431f-b0e4-4e93e4977a63/'
tags:
  - cve.org
epss: 0.00276
epssPercentile: 0.2011
ingestedAt: '2026-11-01T17:57:46.216Z'
---

## Overview

The Community Events WordPress plugin before 1.6.0 does not have authorisation or nonce checks when processing public event submissions, and does not escape several of the submitted values before outputting them in the administration dashboard and on the public calendar, allowing unauthenticated users to inject arbitrary web scripts that will execute in the browser of an administrator reviewing the submission.

## Affected

- `community_events >= 1.4.9 < 1.6.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
