---
id: CVE-2026-87663
title: >-
  An authentication bypass and command injection vulnerability exists in the
  inter-switch remote execution service of Brocade Fabric OS versions before
  9.2.2d and 10.0.0 through 10.0.0a1
summary: >-
  An authentication bypass and command injection vulnerability exists in the
  inter-switch remote execution service of Brocade Fabric OS versions before
  9.2.2d and 10.0.0 through 10.0.0a1. When processing remote command execution
  IPC frames…
severity: medium
cvss: 6.7
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-290
vendor: broadcom
product: fabric_operating_system
affected:
  - fabric_operating_system < 9.2.2d
  - 'fabric_operating_system >= 10.0.0, < 10.0.1'
patched:
  - fabric_operating_system 10.0.1
published: '2026-10-08'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T19:33:03.740'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-87663'
references:
  - url: 'https://support.broadcom.com/external/content/SecurityAdvisories/0/39163'
    label: sirt@brocade.com
tags:
  - nvd
  - cve.org
epss: 0.00666
epssPercentile: 0.5161
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-08T15:18:59.184408Z'
scores:
  nvd: 6.7
  cna: 7.1
ingestedAt: '2026-10-08T05:05:36.682Z'
---

## Overview

An authentication bypass and command injection vulnerability exists in the inter-switch remote execution service of Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1. When processing remote command execution IPC frames across the fabric, the receiving switch processes these commands at an elevated processing level without proper verification of transmitted parameters. This allows an attacker on a single fabric-connected switch to escalate privileges and execute arbitrary root commands locally or across other managed fabric members where remote execution functionality is enabled.

## Affected

- `fabric_operating_system < 9.2.2d`
- `fabric_operating_system >= 10.0.0, < 10.0.1`

## Remediation

Upgrade past the affected range:

- `fabric_operating_system 10.0.1`
