---
id: CVE-2026-87777
title: >-
  The Hostinger Reach  WordPress plugin before 1.8.3 does not sanitize and
  escape a widget setting before outputting it in the editor preview, allowing
  users with contributor-level access and above to inject arbitrary web scripts
  that will…
summary: >-
  The Hostinger Reach  WordPress plugin before 1.8.3 does not sanitize and
  escape a widget setting before outputting it in the editor preview, allowing
  users with contributor-level access and above to inject arbitrary web scripts
  that will…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-79
product: Hostinger Reach
affected:
  - hostinger_reach >= 1.0.6 < 1.8.3
published: '2026-09-30'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T16:28:31.510'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-87777'
references:
  - url: 'https://wpscan.com/vulnerability/4a1f5c2b-a6e5-4e6f-afa3-79726d0eb1e3/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00229
epssPercentile: 0.13583
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-30T13:24:30.747031Z'
ingestedAt: '2026-09-30T06:58:55.554Z'
---

## Overview

The Hostinger Reach  WordPress plugin before 1.8.3 does not sanitize and escape a widget setting before outputting it in the editor preview, allowing users with contributor-level access and above to inject arbitrary web scripts that will execute in the session of a higher-privileged user who opens the affected content in the editor.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
