---
id: CVE-2026-87838
title: >-
  Wava Payment 0.3.1 - 0.3.9 - Unauthenticated Merchant Credential Overwrite via
  Install Webhook
summary: >-
  The Wava Payment Plugin WordPress plugin before 0.3.10 does not perform any
  authorisation, nonce or origin verification on one of its public REST
  endpoints, allowing unauthenticated attackers to overwrite the stored
  credential that ident…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L'
cvssSource: adp
cwe:
  - CWE-862
product: Wava Payment Plugin
affected:
  - wava_payment_plugin >= 0.3.1 < 0.3.10
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-21T10:15:33.993815Z'
published: '2026-10-21'
updated: '2026-10-21'
sourceUpdated: '2026-10-21T10:35:01.578Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-87838'
references:
  - url: 'https://wpscan.com/vulnerability/96f247d7-3007-4728-9cd7-0ea52c96edb3/'
tags:
  - cve.org
ingestedAt: '2026-10-21T06:42:48.174Z'
epss: 0.00275
epssPercentile: 0.20077
---

## Overview

The Wava Payment Plugin WordPress plugin before 0.3.10 does not perform any authorisation, nonce or origin verification on one of its public REST endpoints, allowing unauthenticated attackers to overwrite the stored credential that identifies the merchant account the store's payments are created against, to force the integration into a verified state the site owner never completed, and to remove the payment method from the store's checkout.

## Affected

- `wava_payment_plugin >= 0.3.1 < 0.3.10`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
