---
id: CVE-2026-87970
title: >-
  The If-So Dynamic Content  WordPress plugin before 1.10.2 does not escape a
  request-supplied value before reflecting it in an unauthenticated AJAX
  response that is served as HTML, allowing attackers to execute arbitrary
  JavaScript in the…
summary: >-
  The If-So Dynamic Content  WordPress plugin before 1.10.2 does not escape a
  request-supplied value before reflecting it in an unauthenticated AJAX
  response that is served as HTML, allowing attackers to execute arbitrary
  JavaScript in the…
severity: medium
cvss: 4.7
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N'
cwe:
  - CWE-79
product: If-So Dynamic Content
affected:
  - if-so_dynamic_content >= 1.8 < 1.10.2
published: '2026-10-01'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T13:11:52.923'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-87970'
references:
  - url: 'https://wpscan.com/vulnerability/a0ae7165-0d5b-4f81-b35b-2d9076573530/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-01T10:44:14.852942Z'
ingestedAt: '2026-10-01T06:38:44.652Z'
epss: 0.0017
epssPercentile: 0.06303
---

## Overview

The If-So Dynamic Content  WordPress plugin before 1.10.2 does not escape a request-supplied value before reflecting it in an unauthenticated AJAX response that is served as HTML, allowing attackers to execute arbitrary JavaScript in the browser of a visitor who opens a crafted link.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
