---
id: CVE-2026-88765
title: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 12.3
  to 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 under certain conditions
  could allow an authenticated user to achieve remote code execution by
  importing a…
summary: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 12.3
  to 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 under certain conditions
  could allow an authenticated user to achieve remote code execution by
  importing a…
severity: high
cvss: 8.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-77
  - CWE-787
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 12.3.0, < 19.1.8'
  - 'gitlab >= 19.2.0, < 19.2.6'
  - 'gitlab >= 19.3.0, < 19.3.2'
patched:
  - gitlab 19.3.2
published: '2026-09-15'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T19:07:20.790'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-88765'
references:
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/627435'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/3990469'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-16T03:56:48.231426Z'
ingestedAt: '2026-09-15T17:41:02.975Z'
epss: 0.00675
epssPercentile: 0.52008
---

## Overview

GitLab has remediated an issue in GitLab EE affecting all versions from 12.3 to 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 under certain conditions could allow an authenticated user to achieve remote code execution by importing a specially crafted Git project export to overflow the Unicode conversion buffer used in Advanced Search indexing.

## Affected

- `gitlab >= 12.3.0, < 19.1.8`
- `gitlab >= 19.2.0, < 19.2.6`
- `gitlab >= 19.3.0, < 19.3.2`

## Remediation

Upgrade past the affected range:

- `gitlab 19.3.2`
