---
id: CVE-2026-88809
title: Rancher meta proxy allowlist bypass leading to server-side request forgery
summary: "A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint\_(/meta/proxy). This endpoint is intended to forward requests only to\_ destinations that appear on a configured allowlist. The allowlist decision was evaluate…"
severity: high
cvss: 7.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-918
vendor: SUSE
product: Rancher
affected:
  - Rancher >= 2.15.0 < 2.15.3
  - Rancher >= 2.14.0 < 2.14.7
  - Rancher >= 2.13.0 < 2.13.11
  - Rancher >= 2.12.0 < 2.12.15
  - Rancher >= 2.11.0 < 2.11.19
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T18:55:07.528740Z'
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T18:55:21.073Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-88809'
references:
  - url: 'https://github.com/rancher/rancher/security/advisories/GHSA-f9gf-wh3x-jx3v'
tags:
  - cve.org
epss: 0.00321
epssPercentile: 0.25219
ingestedAt: '2026-11-05T19:30:42.780Z'
---

## Overview

A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to  destinations that appear on a configured allowlist. The allowlist decision was evaluated in a  place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.

## Affected

- `Rancher >= 2.15.0 < 2.15.3`
- `Rancher >= 2.14.0 < 2.14.7`
- `Rancher >= 2.13.0 < 2.13.11`
- `Rancher >= 2.12.0 < 2.12.15`
- `Rancher >= 2.11.0 < 2.11.19`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
