---
id: CVE-2026-89079
title: >-
  The Theme My Login plugin for WordPress is vulnerable to privilege escalation
  via account takeover in versions up to, and including, 7.2.1
summary: >-
  The Theme My Login plugin for WordPress is vulnerable to privilege escalation
  via account takeover in versions up to, and including, 7.2.1. This is due to
  the plugin not properly validating a user's identity prior to updating their
  passw…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-269
vendor: jfarthing84
product: Theme My Login
affected:
  - theme_my_login <= 7.2.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T18:19:42.210'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-89079'
references:
  - url: 'https://plugins.trac.wordpress.org/changeset/3696081/theme-my-login'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/53c548be-b8aa-4949-93f8-7b4d73688540?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - exploit-available
  - cve.org
epss: 0.01631
epssPercentile: 0.76098
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/murrez/CVE-2026-89079'
  nuclei:
    - CVE-2026-89079
  checkedAt: '2026-10-27T19:55:03.880Z'
exploitAvailable: true
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-16T16:48:58.311097Z'
ingestedAt: '2026-10-16T06:00:00.393Z'
---

## Overview

The Theme My Login plugin for WordPress is vulnerable to privilege escalation via account takeover in versions up to, and including, 7.2.1. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for unauthenticated attackers to change arbitrary user's passwords on multi-site setups in certain configurations.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
