---
id: CVE-2026-89100
title: >-
  The Payment Plugins for Stripe WooCommerce plugin for WordPress is vulnerable
  to Reflected Cross-Site Scripting via '#response' URL Fragment in all versions
  up to, and including, 4.0.17 due to insufficient input sanitization and output
  e…
summary: >-
  The Payment Plugins for Stripe WooCommerce plugin for WordPress is vulnerable
  to Reflected Cross-Site Scripting via '#response' URL Fragment in all versions
  up to, and including, 4.0.17 due to insufficient input sanitization and output
  e…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2026-10-10'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T13:30:21.620'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-89100'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-stripe-payment/tags/4.0.14/assets/build/controllers.js#L1
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-stripe-payment/tags/4.0.14/assets/build/dom-events.js#L1
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-stripe-payment/tags/4.0.14/assets/build/gateways.js#L1
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-stripe-payment/tags/4.0.14/assets/build/utils.js#L1
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3726506/woo-stripe-payment/trunk/assets/build/controllers.js
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/57c64bb5-4849-4166-9792-c079b9cbbc17?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00215
epssPercentile: 0.11829
ingestedAt: '2026-10-10T07:26:21.925Z'
vendor: paymentplugins
product: Payment Plugins for Stripe WooCommerce
affected:
  - payment_plugins_for_stripe_woocommerce <= 4.0.17
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-11T12:13:57.711860Z'
---

## Overview

The Payment Plugins for Stripe WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via '#response' URL Fragment in all versions up to, and including, 4.0.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the 'Generic Errors' setting is unchecked, causing getErrorMessage() to return the raw Stripe error string unchanged rather than substituting a mapped safe message.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
