---
id: CVE-2026-89270
title: >-
  Popup Builder <= 4.4.5 - Missing Authorization to Unauthenticated Arbitrary
  Popup Post Trashing via 'post_type' and 'sg_popup_preview_id' Parameters
summary: >-
  The Popup Builder – Create highly converting, mobile friendly marketing
  popups. plugin for WordPress is vulnerable to authorization bypass in all
  versions up to, and including, 4.4.5 This is due to the plugin not properly
  verifying that …
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-862
vendor: popupbuilder
product: 'Popup Builder – Create highly converting, mobile friendly marketing popups.'
affected:
  - >-
    popup_builder_create_highly_converting_mobile_friendly_marketing_popups. <=
    4.4.5
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-02T17:12:44.409365Z'
published: '2026-10-31'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T17:56:30.351Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-89270'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/13af3a6e-d3ef-41f0-9424-fe2c9b17c8bb?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/popup-builder/tags/4.4.5/com/classes/popups/SGPopup.php#L1830
  - url: >-
      https://plugins.trac.wordpress.org/browser/popup-builder/tags/4.4.5/com/classes/Filters.php#L43
  - url: >-
      https://plugins.trac.wordpress.org/browser/popup-builder/tags/4.4.5/com/classes/Filters.php#L435
  - url: >-
      https://plugins.trac.wordpress.org/browser/popup-builder/tags/4.4.5/com/classes/popups/SGPopup.php#L257
  - url: >-
      https://plugins.trac.wordpress.org/browser/popup-builder/tags/4.4.5/com/classes/popups/SGPopup.php#L1826
  - url: 'https://wordpress.org/plugins/popup-builder/'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3755160/popup-builder/trunk/com/classes/popups/SGPopup.php
tags:
  - cve.org
epss: 0.00394
epssPercentile: 0.33813
ingestedAt: '2026-11-05T19:30:42.757Z'
---

## Overview

The Popup Builder – Create highly converting, mobile friendly marketing popups. plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.4.5 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to trash all published popups on the site with a single unauthenticated GET request. The attack is amplified by a second flaw in SGPopup::find(), which returns false for every normally published popup when the sg_popup_preview_id parameter is present, causing the trash branch to fire against every popup on the site simultaneously.

## Affected

- `popup_builder_create_highly_converting_mobile_friendly_marketing_popups. <= 4.4.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
