---
id: CVE-2026-89288
title: >-
  The Fast Courier  WordPress plugin before 5.2.4 does not sanitize and escape a
  value before using it in a SQL query on an unauthenticated REST route,
  allowing unauthenticated attackers to perform SQL injection and read arbitrary
  data fro…
summary: >-
  The Fast Courier  WordPress plugin before 5.2.4 does not sanitize and escape a
  value before using it in a SQL query on an unauthenticated REST route,
  allowing unauthenticated attackers to perform SQL injection and read arbitrary
  data fro…
severity: high
cvss: 8.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N'
cwe:
  - CWE-89
product: Fast Courier
affected:
  - fast_courier >= 5.0.0 < 5.2.4
published: '2026-10-14'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T11:17:53.550'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-89288'
references:
  - url: 'https://wpscan.com/vulnerability/8b651892-fc8a-4c8b-a04d-5c76b5b85577/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00345
epssPercentile: 0.27876
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T10:34:06.956091Z'
ingestedAt: '2026-10-14T07:21:04.845Z'
---

## Overview

The Fast Courier  WordPress plugin before 5.2.4 does not sanitize and escape a value before using it in a SQL query on an unauthenticated REST route, allowing unauthenticated attackers to perform SQL injection and read arbitrary data from the database.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
