---
id: CVE-2026-89293
title: >-
  Missing server-side authorization in Eclipse Mnestix Browser admin server
  actions allows unauthenticated configuration tampering
summary: >-
  In Eclipse Mnestix Browser versions 1.2.0 up until but excluding 2.3.0 it was
  possible for an unauthenticated attacker to perform actions that are only
  allowed to be executed by an authorized Mnestix user, like changing the
  Infrastructur…
severity: high
cvss: 8.8
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-862
  - CWE-602
vendor: Eclipse Foundation
product: Eclipse Mnestix
affected:
  - eclipse_mnestix >= 1.2.0 < 2.3.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-03T20:21:02.766868Z'
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T20:21:20.284Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-89293'
references:
  - url: 'https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/772'
  - url: 'https://gitlab.eclipse.org/security/cve-assignment/-/work_items/301'
tags:
  - cve.org
epss: 0.0046
epssPercentile: 0.39944
ingestedAt: '2026-11-05T20:33:06.444Z'
---

## Overview

In Eclipse Mnestix Browser versions 1.2.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker to perform actions that are only allowed to be executed by an authorized Mnestix user, like changing the Infrastructure settings or calling the connected and authenticated Mnestix AAS Generator backend.

## Affected

- `eclipse_mnestix >= 1.2.0 < 2.3.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
