---
id: CVE-2026-90437
title: >-
  Gravity Forms <= 3.1.1 - Unauthenticated Stored Cross-Site Scripting via Post
  Excerpt / Post Custom Field / Rich-Text Paragraph Field Values
summary: >-
  The Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via Post Excerpt / Post Custom Field / Rich-Text Paragraph Field
  Values in all versions up to, and including, 3.1.1 due to insufficient input
  sanitizatio…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: Gravity Forms
product: Gravity Forms
affected:
  - gravity_forms <= 3.1.1
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-30T17:32:48.518237Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:09:00.650Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-90437'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/7aee2acb-f109-4ba7-91ed-e65868b32f4f?source=cve
  - url: 'https://docs.gravityforms.com/'
tags:
  - cve.org
epss: 0.0019
epssPercentile: 0.0878
ingestedAt: '2026-11-05T16:24:31.314Z'
---

## Overview

The Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Post Excerpt / Post Custom Field / Rich-Text Paragraph Field Values in all versions up to, and including, 3.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because Post Excerpt, Post Custom Field, and Rich-Text-Editor-enabled Paragraph Text fields allow raw HTML submissions via allow_html(), and an entity-encoded payload stored in a data-dialog-confirm attribute evades wp_kses_post() at save time but is decoded into executable markup by the browser when the plugin's admin JavaScript passes the attribute value to insertAdjacentHTML().

## Affected

- `gravity_forms <= 3.1.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
