---
id: CVE-2026-90624
title: >-
  Apache OpenOffice: PDF File Parsing Heap based Buffer-Overflow-Remote Code
  Execution Vulnerability
summary: >-
  An unchecked memory access in the PDF import code of Apache OpenOffice
  versions through 4.1.16 on allows a crafted PDF to execute an out-of-bounds
  memory write. This could crash the program or cause memory corruption.

  Users are recommend…
severity: high
cvss: 7.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L'
cvssSource: adp
cwe:
  - CWE-787
vendor: Apache Software Foundation
product: Apache OpenOffice
affected:
  - apache_openoffice <= 4.1.16
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-04T00:00:00+00:00'
published: '2026-11-04'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T04:55:50.416Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-90624'
references:
  - url: 'https://lists.apache.org/thread.html/w1047xm52vyfjt79kw2n0d3ln6sq9g5s'
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.734Z'
---

## Overview

An unchecked memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 on allows a crafted PDF to execute an out-of-bounds memory write. This could crash the program or cause memory corruption.
Users are recommended to upgrade to version 4.1.17, which fixes this issue.

## Affected

- `apache_openoffice <= 4.1.16`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
