---
id: CVE-2026-91800
title: >-
  A local privilege escalation vulnerability exists in the installer of Foxit
  PDF Editor for macOS due to insufficient validation of a user-modifiable
  configuration value during high-privilege upgrades
summary: >-
  A local privilege escalation vulnerability exists in the installer of Foxit
  PDF Editor for macOS due to insufficient validation of a user-modifiable
  configuration value during high-privilege upgrades. A local attacker could
  exploit this …
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-732
vendor: foxit
product: pdf_editor
affected:
  - pdf_editor <= 13.2.6.63484
  - 'pdf_editor >= 14.0.0.68868, <= 14.0.7.69441'
  - 'pdf_editor >= 2023.1.0.55583, <= 2023.3.0.63083'
  - 'pdf_editor >= 2024.1.0.63682, <= 2024.4.1.66479'
  - 'pdf_editor >= 2025.1.0.66692, <= 2025.3.0.69570'
  - 'pdf_editor >= 2026.1.0.70169, <= 2026.2.0.72029'
  - pdf_reader <= 2026.2.0.72029
published: '2026-09-23'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T15:06:29.017'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-91800'
references:
  - url: 'https://www.foxit.com/support/security-bulletins.html'
    label: 14984358-7092-470d-8f34-ade47a7658a2
tags:
  - nvd
  - cve.org
epss: 0.00151
epssPercentile: 0.04202
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-23T14:45:25.566451Z'
ingestedAt: '2026-09-23T08:20:37.589Z'
---

## Overview

A local privilege escalation vulnerability exists in the installer of Foxit PDF Editor for macOS due to insufficient validation of a user-modifiable configuration value during high-privilege upgrades. A local attacker could exploit this issue to execute arbitrary commands with root privileges.

## Affected

- `pdf_editor <= 13.2.6.63484`
- `pdf_editor >= 14.0.0.68868, <= 14.0.7.69441`
- `pdf_editor >= 2023.1.0.55583, <= 2023.3.0.63083`
- `pdf_editor >= 2024.1.0.63682, <= 2024.4.1.66479`
- `pdf_editor >= 2025.1.0.66692, <= 2025.3.0.69570`
- `pdf_editor >= 2026.1.0.70169, <= 2026.2.0.72029`
- `pdf_reader <= 2026.2.0.72029`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
