---
id: CVE-2026-91809
title: >-
  A use-after-free vulnerability exists in Foxit PDF Editor/Reader’s handling of
  malformed PDF form fields
summary: >-
  A use-after-free vulnerability exists in Foxit PDF Editor/Reader’s handling of
  malformed PDF form fields. Improper validation during field-name traversal may
  cause the application to access a released object, resulting in an application
  …
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-416
vendor: foxit
product: pdf_editor
affected:
  - pdf_editor <= 13.2.5.63482
  - 'pdf_editor >= 14.0.0.33046, <= 14.0.7.33751'
  - 'pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028'
  - 'pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687'
  - 'pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737'
  - 'pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747'
  - pdf_reader <= 2026.2.0.39747
published: '2026-09-23'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T14:04:38.777'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-91809'
references:
  - url: 'https://www.foxit.com/support/security-bulletins.html'
    label: 14984358-7092-470d-8f34-ade47a7658a2
tags:
  - nvd
  - cve.org
epss: 0.0017
epssPercentile: 0.06381
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-23T15:26:26.832912Z'
ingestedAt: '2026-09-23T08:20:37.593Z'
---

## Overview

A use-after-free vulnerability exists in Foxit PDF Editor/Reader’s handling of malformed PDF form fields. Improper validation during field-name traversal may cause the application to access a released object, resulting in an application crash.

## Affected

- `pdf_editor <= 13.2.5.63482`
- `pdf_editor >= 14.0.0.33046, <= 14.0.7.33751`
- `pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028`
- `pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687`
- `pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737`
- `pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747`
- `pdf_reader <= 2026.2.0.39747`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
