---
id: CVE-2026-91832
title: >-
  The WP Mobile Menu  WordPress plugin before 2.9 does not correctly verify the
  nonce on its settings import, so an attacker can import arbitrary WP Mobile
  Menu  WordPress plugin before 2.9 settings through a cross-site request in an
  admin…
summary: >-
  The WP Mobile Menu  WordPress plugin before 2.9 does not correctly verify the
  nonce on its settings import, so an attacker can import arbitrary WP Mobile
  Menu  WordPress plugin before 2.9 settings through a cross-site request in an
  admin…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cwe:
  - CWE-79
  - CWE-352
product: WP Mobile Menu
affected:
  - wp_mobile_menu >= 2.7.4 < 2.9
published: '2026-09-30'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T16:28:31.510'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-91832'
references:
  - url: 'https://wpscan.com/vulnerability/9f1448d5-6dc9-47dd-8675-2fbf5f36393b/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00087
epssPercentile: 0.00342
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-30T13:23:01.642060Z'
ingestedAt: '2026-09-30T06:58:55.557Z'
---

## Overview

The WP Mobile Menu  WordPress plugin before 2.9 does not correctly verify the nonce on its settings import, so an attacker can import arbitrary WP Mobile Menu  WordPress plugin before 2.9 settings through a cross-site request in an administrator's session, and the imported values are then output unescaped to every visitor, resulting in Stored Cross-Site Scripting.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
