---
id: CVE-2026-92086
title: >-
  MW WP Form <= 5.1.7 - Unauthenticated Sensitive Information Exposure in
  'post_id' Parameter
summary: >-
  The MW WP Form plugin for WordPress is vulnerable to Sensitive Information
  Exposure in all versions up to, and including, 5.1.7 via the 'post_id'
  parameter. This makes it possible for unauthenticated attackers to extract
  personally ident…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-200
vendor: websoudan
product: MW WP Form
affected:
  - mw_wp_form <= 5.1.7
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-29T12:17:43.646472Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T12:36:50.947Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-92086'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/7e412f8a-f872-47cf-bbce-554b3559ef8a?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/mw-wp-form/tags/5.1.6/classes/models/class.parser.php#L165
  - url: >-
      https://plugins.trac.wordpress.org/browser/mw-wp-form/tags/5.1.6/classes/models/class.parser.php#L156
  - url: >-
      https://plugins.trac.wordpress.org/browser/mw-wp-form/tags/5.1.6/classes/models/class.parser.php#L208
  - url: 'https://github.com/web-soudan/mw-wp-form/compare/5.1.6...5.1.8'
tags:
  - cve.org
epss: 0.00336
epssPercentile: 0.27107
ingestedAt: '2026-11-01T17:57:46.238Z'
---

## Overview

The MW WP Form plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.1.7 via the 'post_id' parameter. This makes it possible for unauthenticated attackers to extract personally identifiable information from other users' form inquiry records, including submitted names, email addresses, and free-text message bodies, by enumerating sequential post IDs. Exploitation requires the targeted form to have the querystring setting enabled, but this is a standard documented feature of the plugin.

## Affected

- `mw_wp_form <= 5.1.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
