---
id: CVE-2026-92098
title: >-
  Webheadcoder Multi-Step Forms for Contact Form 7 <= 4.7 - Reflected Cross-Site
  Scripting via 'l10n_print_after' Parameter
summary: >-
  The Webheadcoder Multi-Step Forms for Contact Form 7 plugin for WordPress is
  vulnerable to Reflected Cross-Site Scripting via the 'l10n_print_after'
  parameter in all versions up to, and including, 4.7 due to insufficient input
  sanitizati…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: webheadllc
product: Webheadcoder Multi-Step Forms for Contact Form 7
affected:
  - webheadcoder_multi-step_forms_for_contact_form_7 <= 4.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-28T14:36:28.512515Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T16:09:47.127Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-92098'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/6fa810af-e620-49e5-9be0-f9fc4d09ed6d?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php#L180
  - url: >-
      https://plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php#L1444
  - url: >-
      https://plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php#L225
  - url: >-
      https://plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php#L395
  - url: >-
      https://github.com/coreyt808/webheadcoder-multi-step-forms-for-contact-form-7/commit/16f71561797b71548021dc9c4e30b0456e718cd3
  - url: >-
      https://plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7.1/cf7msm.php
tags:
  - cve.org
epss: 0.00215
epssPercentile: 0.11984
ingestedAt: '2026-10-28T07:06:27.114Z'
---

## Overview

The Webheadcoder Multi-Step Forms for Contact Form 7 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'l10n_print_after' parameter in all versions up to, and including, 4.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Successful exploitation requires that the targeted site has at least one Contact Form 7 form configured with a [multistep] form-tag, as the canonicalization introduced in version 4.7 blocks the attack path on non-multistep forms.

## Affected

- `webheadcoder_multi-step_forms_for_contact_form_7 <= 4.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
