---
id: CVE-2026-92099
title: >-
  The WPGraphQL Smart Cache WordPress plugin before 2.3.2 does not require
  authorisation or validate a caller-supplied query identifier before storing a
  persisted query from a request, allowing unauthenticated users to publish
  arbitrary qu…
summary: >-
  The WPGraphQL Smart Cache WordPress plugin before 2.3.2 does not require
  authorisation or validate a caller-supplied query identifier before storing a
  persisted query from a request, allowing unauthenticated users to publish
  arbitrary qu…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L'
cwe:
  - CWE-284
product: WPGraphQL Smart Cache
affected:
  - wpgraphql_smart_cache < 2.3.2
published: '2026-09-19'
updated: '2026-09-21'
sourceUpdated: '2026-09-21T13:34:57.127'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92099'
references:
  - url: 'https://wpscan.com/vulnerability/3563529f-5050-4f92-9a3c-44ee850254bd/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
  - exploit-available
epss: 0.00343
epssPercentile: 0.27669
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-19T13:11:34.510384Z'
ingestedAt: '2026-09-19T06:59:13.119Z'
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/MS-0x404/CVE-2026-92099'
  checkedAt: '2026-10-27T19:22:28.902Z'
exploitAvailable: true
---

## Overview

The WPGraphQL Smart Cache WordPress plugin before 2.3.2 does not require authorisation or validate a caller-supplied query identifier before storing a persisted query from a request, allowing unauthenticated users to publish arbitrary query documents and claim query aliases before a site's own frontend registers them.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
