---
id: CVE-2026-92294
title: >-
  Spectra Gutenberg Blocks <= 2.20.4 - Missing Authorization to Unauthenticated
  Limited Theme File Deletion and Modification via 'page', 'path', and
  'settings' GET Parameters
summary: >-
  The Spectra Gutenberg Blocks – Website Builder for the Block Editor plugin for
  WordPress is vulnerable to limited file deletion due to insufficient file path
  validation in the '__construct' function in all versions up to, and including,
  …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-862
vendor: brainstormforce
product: Spectra Legacy – Gutenberg Blocks
affected:
  - spectra_legacy_gutenberg_blocks <= 2.20.4
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-03T19:01:55.369822Z'
published: '2026-10-31'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T19:02:04.839Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-92294'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/60ad515a-3c0b-47f5-919b-0d17f693c049?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L101
  - url: >-
      https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L93
  - url: >-
      https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-fse-fonts-compatibility.php#L584
  - url: >-
      https://plugins.trac.wordpress.org/browser/ultimate-addons-for-gutenberg/tags/2.19.21/classes/class-uagb-loader.php#L302
  - url: 'https://plugins.trac.wordpress.org/changeset/3736176/'
tags:
  - cve.org
epss: 0.00444
epssPercentile: 0.38849
ingestedAt: '2026-11-05T20:33:06.376Z'
---

## Overview

The Spectra Gutenberg Blocks – Website Builder for the Block Editor plugin for WordPress is vulnerable to limited file deletion due to insufficient file path validation in the '__construct' function in all versions up to, and including, 2.20.4 This makes it possible for unauthenticated attackers to delete theme files on the server.

## Affected

- `spectra_legacy_gutenberg_blocks <= 2.20.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
