---
id: CVE-2026-92396
title: Blocks for ShopEngine < 2.4.4 - Contributor+ Stored XSS via gutenova_store_css
summary: >-
  The ShopEngine Gutenberg WooCommerce Builder Blocks Addon  WordPress plugin
  before 2.4.4 does not validate the user's capabilities or the ownership of the
  targeted post in one of its AJAX actions, and does not escape the stored value
  bef…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'
cvssSource: adp
cwe:
  - CWE-79
product: ShopEngine Gutenberg WooCommerce Builder Blocks Addon
affected:
  - shopengine_gutenberg_woocommerce_builder_blocks_addon < 2.4.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-06T11:44:37.640273Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T11:56:59.126Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-92396'
references:
  - url: 'https://wpscan.com/vulnerability/f7db6391-4873-4de9-b300-456f3c9b7146/'
tags:
  - cve.org
ingestedAt: '2026-11-06T06:46:27.278Z'
epss: 0.00235
epssPercentile: 0.14591
---

## Overview

The ShopEngine Gutenberg WooCommerce Builder Blocks Addon  WordPress plugin before 2.4.4 does not validate the user's capabilities or the ownership of the targeted post in one of its AJAX actions, and does not escape the stored value before outputting it in a JavaScript context, allowing users with a role as low as contributor to inject arbitrary scripts into any post that will run when a higher privileged user edits it.

## Affected

- `shopengine_gutenberg_woocommerce_builder_blocks_addon < 2.4.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
