---
id: CVE-2026-92415
title: >-
  — Use of Externally-Controlled Input to Select Classes or Code vulnerability
  in Apache Jackrabbit's WebDAV/Davex client.


  A malicious WebDAV/DavEx server, or an attacker able to intercept the
  connection, can cause the client to instantia…
summary: >-
  — Use of Externally-Controlled Input to Select Classes or Code vulnerability
  in Apache Jackrabbit's WebDAV/Davex client.


  A malicious WebDAV/DavEx server, or an attacker able to intercept the
  connection, can cause the client to instantia…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-470
vendor: apache
product: jackrabbit
affected:
  - 'jackrabbit >= 2.20.0, < 2.20.18'
  - 'jackrabbit >= 2.22.0, < 2.22.5'
  - 'jackrabbit >= 2.23.0, < 2.23.6'
patched:
  - jackrabbit 2.23.6
published: '2026-10-07'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T14:24:47.540'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92415'
references:
  - url: 'https://lists.apache.org/thread.html/hcrxm4jp1mtk56xb8p1dtryz7hl08kmr'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/10/07/28'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
epss: 0.00549
epssPercentile: 0.45794
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-07T20:29:38.090473Z'
scores:
  nvd: 5.3
  cna: 6.9
ingestedAt: '2026-10-07T16:38:22.230Z'
---

## Overview

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client.

A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation.

Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected.

Category: unsafe reflection on wire data (HIGH).



This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17.



Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

## Affected

- `jackrabbit >= 2.20.0, < 2.20.18`
- `jackrabbit >= 2.22.0, < 2.22.5`
- `jackrabbit >= 2.23.0, < 2.23.6`

## Remediation

Upgrade past the affected range:

- `jackrabbit 2.23.6`
