---
id: CVE-2026-92528
title: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 16.11
  before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain
  conditions, could have allowed an authenticated user to approve a merge
  request d…
summary: >-
  GitLab has remediated an issue in GitLab EE affecting all versions from 16.11
  before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain
  conditions, could have allowed an authenticated user to approve a merge
  request d…
severity: medium
cvss: 4.2
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N'
cwe:
  - CWE-863
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 16.11.0, < 19.2.8'
  - 'gitlab >= 19.3.0, < 19.3.5'
  - 'gitlab >= 19.4.0, < 19.4.2'
patched:
  - gitlab 19.4.2
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T20:18:00.627'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92528'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/606772'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
epss: 0.00131
epssPercentile: 0.02666
ingestedAt: '2026-10-13T03:13:18.999Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-14T19:12:58.219818Z'
---

## Overview

GitLab has remediated an issue in GitLab EE affecting all versions from 16.11 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to approve a merge request despite having contributed commits to it, due to improper identity resolution.

## Affected

- `gitlab >= 16.11.0, < 19.2.8`
- `gitlab >= 19.3.0, < 19.3.5`
- `gitlab >= 19.4.0, < 19.4.2`

## Remediation

Upgrade past the affected range:

- `gitlab 19.4.2`
