---
id: CVE-2026-92564
title: >-
  A pre-authentication attacker could leverage type nesting to cause a
  StackOverflowError potentially leading to denial of service.


  This issue affects Apache Qpid Broker-J: through 10.1.0.


  Users are recommended to upgrade to version 10.1…
summary: >-
  A pre-authentication attacker could leverage type nesting to cause a
  StackOverflowError potentially leading to denial of service.


  This issue affects Apache Qpid Broker-J: through 10.1.0.


  Users are recommended to upgrade to version 10.1…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-674
  - CWE-770
vendor: apache
product: qpid_broker-j
affected:
  - qpid_broker-j < 10.1.1
patched:
  - qpid_broker-j 10.1.1
published: '2026-09-25'
updated: '2026-10-05'
sourceUpdated: '2026-10-05T18:04:01.700'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92564'
references:
  - url: 'https://lists.apache.org/thread/hw4jkngtkzf0dxdj9mv3z2p71mkpjvx4'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/09/24/14'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-92564.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-92564'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2540988'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-92564'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92564'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00483
epssPercentile: 0.41444
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-25T13:23:29.728672Z'
ingestedAt: '2026-09-25T09:05:19.678Z'
---

## Overview

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid Broker-J: through 10.1.0.

Users are recommended to upgrade to version 10.1.1, which fixes the issue.

## Affected

- `qpid_broker-j < 10.1.1`

## Remediation

Upgrade past the affected range:

- `qpid_broker-j 10.1.1`

## Vendor advisories

- **Red Hat VEX** · Important · updated 2026-10-02 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-92564.json)
