---
id: CVE-2026-92766
title: >-
  The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is
  vulnerable to generic SQL Injection via the 'src_by' parameter in all versions
  up to, and including, 3.5.1 due to insufficient escaping on the user supplied
  parame…
summary: >-
  The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is
  vulnerable to generic SQL Injection via the 'src_by' parameter in all versions
  up to, and including, 3.5.1 due to insufficient escaping on the user supplied
  parame…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-89
vendor: appsbd
product: Vitepos – Point of Sale (POS) for WooCommerce
affected:
  - vitepos_point_of_sale_pos_for_woocommerce <= 3.5.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:35.763'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92766'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.5.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v5/core/class-basemodel.php#L2877
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.5.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v5/core/class-basemodel.php#L741
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.5.1/vendor/appsbd-wp/appsbd-lite/appsbd_lite/v5/core/class-querybuilder.php#L150
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.5.1/vitepos_lite/api/v1/class-pos-vendor-api.php#L64
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/vitepos-lite/tags/3.5.1/vitepos_lite/api/v1/class-pos-vendor-api.php#L79
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3700375%40vitepos-lite&new=3700375%40vitepos-lite
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/7549e2f1-1ba9-4cd4-b2c2-6812d48e1590?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.0033
epssPercentile: 0.2594
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-16T14:54:24.855136Z'
ingestedAt: '2026-10-16T09:03:22.690Z'
---

## Overview

The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to generic SQL Injection via the 'src_by' parameter in all versions up to, and including, 3.5.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This makes it possible for unauthenticated attackers, or authenticated attackers holding any POS role (such as vtpos-cashier), to exploit the vulnerability, as the /vitepos/v1/vendor/list REST route's permission callback requires only a POS role assignment rather than any elevated WordPress capability.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
