---
id: CVE-2026-92874
title: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  18.3 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under
  certain conditions could have allowed an authenticated user with an MCP-scoped
  token to …
summary: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  18.3 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under
  certain conditions could have allowed an authenticated user with an MCP-scoped
  token to …
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'
cwe:
  - CWE-863
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 18.3.0, < 19.2.7'
  - 'gitlab >= 19.3.0, < 19.3.3'
  - gitlab = 19.4.0
patched:
  - gitlab 19.3.3
published: '2026-09-24'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T15:22:41.523'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92874'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/618614'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
epss: 0.00146
epssPercentile: 0.03787
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-24T13:09:38.009631Z'
ingestedAt: '2026-09-23T23:34:46.861Z'
---

## Overview

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.3 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with an MCP-scoped token to perform actions beyond the intended scope of that token due to improper authorization checks.

## Affected

- `gitlab >= 18.3.0, < 19.2.7`
- `gitlab >= 19.3.0, < 19.3.3`
- `gitlab = 19.4.0`

## Remediation

Upgrade past the affected range:

- `gitlab 19.3.3`
