---
id: CVE-2026-92883
title: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2  that, under
  certain conditions, could have allowed an authenticated user to execute
  arbitrary Java…
summary: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2  that, under
  certain conditions, could have allowed an authenticated user to execute
  arbitrary Java…
severity: high
cvss: 8.7
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N'
cwe:
  - CWE-79
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 19.1.0, < 19.2.8'
  - 'gitlab >= 19.3.0, < 19.3.5'
  - 'gitlab >= 19.4.0, < 19.4.2'
patched:
  - gitlab 19.4.2
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T20:18:00.737'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92883'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/629523'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/3936831'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
epss: 0.00478
epssPercentile: 0.41037
ingestedAt: '2026-10-13T03:13:18.999Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-14T19:13:29.537743Z'
---

## Overview

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2  that, under certain conditions, could have allowed an authenticated user to execute arbitrary JavaScript in the context of other users' browser sessions via a specially crafted repository, due to improper sanitization of HTML attributes in syntax-highlighted output.

## Affected

- `gitlab >= 19.1.0, < 19.2.8`
- `gitlab >= 19.3.0, < 19.3.5`
- `gitlab >= 19.4.0, < 19.4.2`

## Remediation

Upgrade past the affected range:

- `gitlab 19.4.2`
