---
id: CVE-2026-92950
title: >-
  vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that
  allows attackers to execute arbitrary code in the host Node.js process
summary: >-
  vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that
  allows attackers to execute arbitrary code in the host Node.js process.
  Attackers can supply a malicious script file to the vm2 CLI that uses
  require(__filena…
severity: high
cvss: 8.6
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H'
cwe:
  - CWE-453
  - CWE-829
  - CWE-1188
vendor: patriksimek
product: vm2
affected:
  - vm2 < 3.11.7
published: '2026-09-17'
updated: '2026-09-17'
sourceUpdated: '2026-09-17T15:17:00.910'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92950'
references:
  - url: 'https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vm2-before-3.11.7-sandbox-escape-via-cli-require
    label: disclosure@vulncheck.com
  - url: 'https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-92950'
  - url: >-
      https://github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86
  - url: 'https://github.com/patriksimek/vm2/releases/tag/v3.11.7'
  - url: 'https://github.com/advisories/GHSA-jxxv-8r27-vm4p'
tags:
  - nvd
  - cve.org
  - exploit-available
  - ghsa
  - npm
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-17T14:24:09.586860Z'
ingestedAt: '2026-09-17T14:19:30.988Z'
epss: 0.00197
epssPercentile: 0.0938
aliases:
  - GHSA-jxxv-8r27-vm4p
ecosystem: npm
patched:
  - vm2 3.11.7
---

## Overview

vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process. Attackers can supply a malicious script file to the vm2 CLI that uses require(__filename) to re-execute itself in the host realm, bypassing sandbox isolation and accessing host modules like fs and child_process.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-92950)

Affected packages:

- `vm2 <= 3.11.6`

Patched in:

- `vm2 3.11.7`

Source: https://github.com/advisories/GHSA-jxxv-8r27-vm4p
