---
id: CVE-2026-93577
title: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under
  certain conditions could have allowed an authenticated user to execute
  arbitrary code on…
summary: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under
  certain conditions could have allowed an authenticated user to execute
  arbitrary code on…
severity: critical
cvss: 9.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-190
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 19.2.0, < 19.2.7'
  - 'gitlab >= 19.3.0, < 19.3.3'
  - gitlab = 19.4.0
patched:
  - gitlab 19.3.3
published: '2026-09-24'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T15:22:15.293'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-93577'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/629758'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/3995696'
    label: cve@gitlab.com
tags:
  - nvd
  - cve.org
epss: 0.00593
epssPercentile: 0.48114
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-24T13:11:55.991696Z'
ingestedAt: '2026-09-23T23:34:46.861Z'
---

## Overview

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.

## Affected

- `gitlab >= 19.2.0, < 19.2.7`
- `gitlab >= 19.3.0, < 19.3.3`
- `gitlab = 19.4.0`

## Remediation

Upgrade past the affected range:

- `gitlab 19.3.3`
