---
id: CVE-2026-93592
title: >-
  vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in
  the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers
  to crash the engine by submitting negative token IDs
summary: >-
  vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in
  the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers
  to crash the engine by submitting negative token IDs. A single request with a
  nega…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-129
  - CWE-617
vendor: vllm
product: vllm
affected:
  - vllm < 0.28.0
patched:
  - vllm 0.28.0
published: '2026-09-18'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T18:37:06.063'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-93592'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-25q3-v2hm-8vpf
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vllm-before-0.28.0-denial-of-service-via-negative-token-id
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-25q3-v2hm-8vpf
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-93592.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-93592'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2538478'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-93592'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-93592'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83112'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83120'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83121'
  - url: 'https://access.redhat.com/errata/RHSA-2026:83114'
  - url: 'https://access.redhat.com/errata/RHSA-2026:82061'
  - url: 'https://access.redhat.com/errata/RHSA-2026:84734'
tags:
  - nvd
  - cve.org
  - exploit-available
  - csaf
  - vex
  - red-hat
  - osv
  - pip
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-18T18:09:16.556315Z'
ingestedAt: '2026-09-18T13:41:41.665Z'
epss: 0.00544
epssPercentile: 0.455
aliases:
  - PYSEC-2026-3997
  - GHSA-25q3-v2hm-8vpf
ecosystem: pip
---

## Overview

vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.

## Affected

- `vllm < 0.28.0`

## Remediation

Upgrade past the affected range:

- `vllm 0.28.0`

## Vendor advisories

- **Red Hat VEX** · Important · affected: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · no fix planned: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · updated 2026-10-19 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-93592.json)
- **RHSA-2026:83112** · Red Hat · fixed in: Red Hat AI Inference Server 3.4 · released 2026-10-14 · [advisory](https://access.redhat.com/errata/RHSA-2026:83112)
- **RHSA-2026:83120** · Red Hat · fixed in: Red Hat AI Inference Server 3.4 · released 2026-10-14 · [advisory](https://access.redhat.com/errata/RHSA-2026:83120)
- **RHSA-2026:83121** · Red Hat · fixed in: Red Hat AI Inference Server 3.4 · released 2026-10-14 · [advisory](https://access.redhat.com/errata/RHSA-2026:83121)
- **RHSA-2026:83114** · Red Hat · fixed in: Red Hat AI Inference Server 3.4 · released 2026-10-14 · [advisory](https://access.redhat.com/errata/RHSA-2026:83114)
- **RHSA-2026:82061** · Red Hat · fixed in: Red Hat AI Inference Server 3.5 · released 2026-10-13 · [advisory](https://access.redhat.com/errata/RHSA-2026:82061)
- **RHSA-2026:84734** · Red Hat · fixed in: Red Hat OpenShift AI 3.4 · released 2026-10-19 · [advisory](https://access.redhat.com/errata/RHSA-2026:84734)

## Package advisory (CVE-2026-93592)

Affected packages:

- `vllm < 0.28.0`

Patched in:

- `vllm 0.28.0`

Source: https://osv.dev/vulnerability/PYSEC-2026-3997
