---
id: CVE-2026-93675
title: >-
  IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote attacker to execute
  arbitrary code due to an expected dependency confusion.
summary: >-
  IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote attacker to execute
  arbitrary code due to an expected dependency confusion.
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-440
vendor: langflow
product: langflow
affected:
  - 'langflow >= 1.0.0, < 1.12.3'
patched:
  - langflow 1.12.3
published: '2026-10-07'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T18:25:15.810'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-93675'
references:
  - url: 'https://www.ibm.com/support/pages/node/7290694'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00625
epssPercentile: 0.4974
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-07T16:32:09.448335Z'
ingestedAt: '2026-10-07T01:27:17.513Z'
---

## Overview

IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote attacker to execute arbitrary code due to an expected dependency confusion.

## Affected

- `langflow >= 1.0.0, < 1.12.3`

## Remediation

Upgrade past the affected range:

- `langflow 1.12.3`
